Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
NFS version 4 and idmapd under Redhat Linuxes
12-03-2013, 08:25 AM (This post was last modified: 12-03-2013 08:27 AM by Nanook.)
Post: #1
NFS version 4 and idmapd under Redhat Linuxes
This applies to any Redhat derived Linux, Fedora, CentOS, Scientific Linux, and possibly other operating systems using NFSv4.

Recently after an update, around November 20th, 2013, to our servers running CentOS 6.4, we ran into problems with NFS mounted files showing up with an ownership of nobody.

We've been using NFSv4 to mount files off a file server for over a year with no problem. I had never configured idmapd or made sure that it was running, yet, until this recent update everything worked.

In order to get things working again, it was necessary to set the domain in idmapd and make sure idmapd was running.

To do this, edit /etc/idmapd.conf, the beginning of the file you'll see something like this:

Domain = somedomain.com

If this is commented out, or if the domain isn't correct, idmapd will not function properly and NFSv4 ownership mapping will be broken.

Usually, the domain is the same as your NIS domain but it may be different. The important thing is that it be the same on the server and client machines.

Then in System->Administration->Services, make sure rpcidmapd
is enabled.

From a shell prompt type:

ps aux | grep idmapd

To make sure it is running and you may want to reboot and do that again to make sure it gets properly started after a reboot.
Quote


Forum Jump:


User(s) browsing this thread: 1 Guest(s)