Re: Spectro Acoustics Designers and Tech's


[ Follow Ups ] [ Post Followup ] [ TAPCO web forum ] [ FAQ ]

Posted by Brandon (209.240.222.132) on May 13, 2002 at 21:18:17:

In Reply to: Re: Spectro Acoustics Designers and Tech's posted by Keith Taylor on March 12, 2002 at 07:55:52:


: Hello, Curtis-

: I have a SpectroAcoustics 500SR power amp which I purchased new in January of 1978. For many trouble-free years I have used this amp in my studio. Recently the amp stopped working although it was simply just the bridge rectifier which finally gave up the ghost. It was down for only a half day and is now back in the rack functioning perfectly (as an EE by trade, I generally service my own components).

: During these years of ownership, I made a couple of minor mods to the amp although none of these involved any changes to the audio path. I installed a power-on status LED on the front panel which I felt the amp certainly needed and I replaced the RCA input jacks with 1/4" just for added reliability as well as compatibility with my other studio components. The 1/4" inputs could very quickly be converted back to the RCA-type although I don't know why anyone would really want to do that. Oh yes, I also replaced the level potentiometers after they became noisy with Bourns sealed conductive-plastic pots.

: Although this has been a very trusty piece of gear (it is by far the oldest piece in my racks), I will soon be replacing it as I am purchasing a pair of Genelec 1030A active nearfield monitors which do not require an external power amp. If you think you might be interested in acquiring another 500SR which I can assure you is in perfect working order, please contact me.

: Regards-
: Keith




Follow Ups:



Post a Followup

Name:
E-Mail:

Subject:

Comments:

Optional Link URL:
Link Title:
Optional Image URL:


[ Follow Ups ] [ Post Followup ] [ TAPCO web forum ] [ FAQ ]