Freak Vulnerability

     Also tested for FREAK, not vulnerable to that attack as well.

     Both of these vulnerabilities exploit capabilities for browser to fall-back to less secure “export” encryption and are mostly an issue with old browsers.

    On this site, we don’t support these flawed encryption standards but you can protect yourself on other sites that do by upgrading your browser to the current version.  Those of you stuck with old versions of Explorer because Microsoft didn’t make newer versions available for older operating systems can either obtain a patch from Microsoft or use an alternative browser like Firefox.

Leave a Reply